[Flent-users] [tohojo/flent] Unable to use flent-gui from 83d14d68 (#167)

Sebastian Moeller moeller0 at gmx.de
Tue Jul 16 01:29:56 EEST 2019


Mmmh, so I installed qtpy (and dependencies) I now get:

./run-flent --gui
Started Flent 1.9.9-git-43e16d5 using Python 3.7.4.
Initialised matplotlib v3.1.1 on numpy v1.16.4.
GUI loaded. Using Qt through pyqt5 v5.12.3.
objc[13628]: Class FIFinderSyncExtensionHost is implemented in both /System/Library/PrivateFrameworks/FinderKit.framework/Versions/A/FinderKit (0x7fff9b6ec3d8) and /System/Library/PrivateFrameworks/FileProvider.framework/OverrideBundles/FinderSyncCollaborationFileProviderOverride.bundle/Contents/MacOS/FinderSyncCollaborationFileProviderOverride (0x12662cf50). One of the two will be used. Which one is undefined.
ERROR: Error while loading data file: '<built-in function connectSlotsByName> returned a result with an error set'. Skipping.

The GUI opens again, but I still see the same lock-up that Pete initially saw. Going to bed for now, maybe I find time to poke this tomorrow...

Thanks!



> On Jul 16, 2019, at 00:16, Toke Høiland-Jørgensen <toke at toke.dk> wrote:
> 
> Sebastian Moeller <moeller0 at gmx.de> writes:
> 
>> Okay, same issue on macosx 10.14.5. Now with the latest changes and PySide2 installed I get:
>> 
>> 
>> ./run-flent --version
>> Flent v1.9.9-git-43e16d5.
>> Running on Python 3.7.4 (default, Jul 11 2019, 01:08:00)  [Clang 10.0.1 (clang-1001.0.46.4)].
>> Using matplotlib version 3.1.1 on numpy 1.16.4.
>> Using PyQt5 version 5.12.2.
>> 
>> 
>> 
>> ./run-flent --gui
>> Started Flent 1.9.9-git-43e16d5 using Python 3.7.4.
>> ERROR: Unable to find a usable Qt version.
>> 
>> Same Qt version "worked" before the latest changes; the quotes as I
>> saw the same error as Pete.
> 
> You probably need to 'pip install QtPy' first... Will try to document
> that somewhere :)




More information about the Flent-users mailing list