[Flent-users] [tohojo/flent] Unable to use flent-gui from 83d14d68 (#167)

Sebastian Moeller moeller0 at gmx.de
Tue Jul 16 01:07:25 EEST 2019


Okay, same issue on macosx 10.14.5. Now with the latest changes and PySide2 installed I get:


./run-flent --version
Flent v1.9.9-git-43e16d5.
Running on Python 3.7.4 (default, Jul 11 2019, 01:08:00)  [Clang 10.0.1 (clang-1001.0.46.4)].
Using matplotlib version 3.1.1 on numpy 1.16.4.
Using PyQt5 version 5.12.2.



./run-flent --gui
Started Flent 1.9.9-git-43e16d5 using Python 3.7.4.
ERROR: Unable to find a usable Qt version.

Same Qt version "worked" before the latest changes; the quotes as I saw the same error as Pete.

If I can do anything on my side to fix/debug this, please let me know. Also let me know if I am just stupid and dod something wrong...


Best Regards
	Sebastian

> On Jul 15, 2019, at 23:09, Toke Høiland-Jørgensen <notifications at github.com> wrote:
> 
> Pete Heist <notifications at github.com> writes:
> 
> > Ah, ok, well it looks like PySide2 has a more permissive license
> > anyway, although I guess that shouldn't affect flent. I haven't
> > noticed any other problems using it, although my testing has hardly
> > been extensive.
> 
> Yeah, PySide2 are the officially supported Python bindings from upstream
> Qt, so guess it's good to support that anyway (PyQt5 predates it
> somewhat). And it's not a huge cost to carry the compatibility layer, so
> I guess I can keep it like this...
>> You are receiving this because you commented.
> Reply to this email directly, view it on GitHub, or mute the thread.
> 
> _______________________________________________
> Flent-users mailing list
> Flent-users at flent.org
> http://flent.org/mailman/listinfo/flent-users_flent.org




More information about the Flent-users mailing list