[Flent-users] IRTT question

Toke Høiland-Jørgensen toke at toke.dk
Fri Feb 9 15:23:37 EET 2018


Pete Heist <peteheist at gmail.com> writes:

>> On Feb 9, 2018, at 11:36 AM, Toke Høiland-Jørgensen <toke at toke.dk> wrote:
>> 
>> Sebastian Moeller <moeller0 at gmx.de> writes:
>> 
>>> Hi Toke,
>>> 
>>> Ah, great, this got me a bit further:
>>> 
>>> UDP RTT test: Cannot use irtt runner (Irtt connection check failed:
>>> [InvalidServerRestriction] server tried to reduce interval to < 1s,
>>> from 1s to 92ns ). Using netperf UDP_RR
>> 
>> Huh, this looks like a bug? Pete?
>
> Ewe. The protocol is versioned now so we won’t see this going forward
> with newer versions (he said hopefully). I updated the faq with this
> info, thanks for testing!

Yes, always version your protocols ;)

> I ran a few tests (on my Mac) to netperf-eu.bufferbloat.net with AQM
> off, which look good (more on that later). I do see an error code from
> fping, but I don’t see any problem with the results:

I think this may just be because Flent ends up killing fping before it
exits by itself. There's no timeout feature of Fping, so it sometimes
ends up running long. There's a watchdog timer in Flent that will kill
it in this case...

-Toke




More information about the Flent-users mailing list